понеділок, 4 травня 2009 р.

Google Earth 5 в Ubuntu 9.04

Всім гарний новий Google Earth 5 але встановивши його на Ubuntu 9.04 можна побачити цікавий глюк - відсутність підтримки кирилиці у меню, та багатьох інших елементах GUI. Насправді проблема полягає в тому, що в дистрибутив Google Earth входять свої бібліотеки Qt4. Достатньо зайти у каталог з встановленою програмою і просто знищити всі файли *.so які починаються на "libQt". Якщо боїтеся знищувати, то можна просто перейменувати:
mv libQtCore.so.4 libQtCore.so.4.dist
mv libQtGui.so.4 libQtGui.so.4.dist
mv libQtNetwork.so.4 libQtNetwork.so.4.dist
mv libQtWebKit.so.4 libQtWebKit.so.4.dist

Тепер достатньо просто встановити Qt4 зі стандартних репозиторіїв, за умови, що ці бібліотеки у вас вже не стоять. Тепер Google Earth матиме нормальний вигляд.