понеділок, 4 травня 2009 р.

Google Earth 5 в Ubuntu 9.04

Всім гарний новий Google Earth 5 але встановивши його на Ubuntu 9.04 можна побачити цікавий глюк - відсутність підтримки кирилиці у меню, та багатьох інших елементах GUI. Насправді проблема полягає в тому, що в дистрибутив Google Earth входять свої бібліотеки Qt4. Достатньо зайти у каталог з встановленою програмою і просто знищити всі файли *.so які починаються на "libQt". Якщо боїтеся знищувати, то можна просто перейменувати:
mv libQtCore.so.4 libQtCore.so.4.dist
mv libQtGui.so.4 libQtGui.so.4.dist
mv libQtNetwork.so.4 libQtNetwork.so.4.dist
mv libQtWebKit.so.4 libQtWebKit.so.4.dist

Тепер достатньо просто встановити Qt4 зі стандартних репозиторіїв, за умови, що ці бібліотеки у вас вже не стоять. Тепер Google Earth матиме нормальний вигляд.

5 коментарів:

  1. Якщо не помиляюсь, то на цьому глюки не закінчуються. Фотки із панараміо відкриваються?
    У мене не відкривались, поки в /opt/google-earth/qt.conf не прописав замість "[PATH]" не прописав
    [Paths]
    Documentation=/usr/share/doc
    Libraries=/usr/lib
    Plugins=/usr/lib/qt4/plugins
    Translations=/usr/lib/qt4/translations

    ВідповістиВидалити
  2. У меня этого глюка нет. Подключил репозиторий Medibuntu, установил Google Earth 5 и никаких проблем.

    ВідповістиВидалити
  3. Я також ставив Google Earth 5 з Medibuntu. Ніяких глюків ні з кирилицею, ні з Panoramio.
    Чесно кажучи, іншими способами встановлення Google Earth та інших програм, ніж з Medibuntu, за останні 2 роки не користувався.

    ВідповістиВидалити
  4. Угу, я в даному випадку говорив про дистрибутив Google Earth з офіційного сайту.

    ВідповістиВидалити
  5. У мене була проблема з Panoramio, вилыкував за рецептом Moses'а

    ВідповістиВидалити